2 years agoupdate list of backends and optional dependencies
Karen Etheridge [Thu, 1 Aug 2019 23:43:25 +0000]
update list of backends and optional dependencies

2 years agoremove mention of zero bugs
Karen Etheridge [Thu, 1 Aug 2019 23:53:36 +0000]
remove mention of zero bugs

2 years agotest on latest perls
Karen Etheridge [Thu, 1 Aug 2019 23:40:12 +0000]
test on latest perls

3 years agoadd travis config
Graham Knop [Tue, 8 May 2018 05:30:19 +0000]
add travis config

4 years agoRelease commit for 0.32 v0.32
Graham Knop [Sun, 23 Apr 2017 21:52:19 +0000]
Release commit for 0.32

4 years agoBumping version to 0.32
Graham Knop [Sun, 23 Apr 2017 21:47:55 +0000]
Bumping version to 0.32

4 years agochangelog
Graham Knop [Sun, 23 Apr 2017 21:26:43 +0000]
changelog

4 years agoallow YAML::Syck to fail the error tests
Graham Knop [Sun, 23 Apr 2017 21:45:31 +0000]
allow YAML::Syck to fail the error tests

4 years agoimprove diagnostics in yaml test
Graham Knop [Sun, 23 Apr 2017 21:45:09 +0000]
improve diagnostics in yaml test

4 years agoprereq report test
Graham Knop [Sun, 23 Apr 2017 21:23:54 +0000]
prereq report test

4 years agoproperly document JSON modules used
Graham Knop [Sun, 23 Apr 2017 21:20:33 +0000]
properly document JSON modules used

4 years agoless strict error check
Graham Knop [Sun, 23 Apr 2017 20:48:46 +0000]
less strict error check

4 years agoRelease commit for 0.31 v0.31
Graham Knop [Sun, 23 Apr 2017 19:43:08 +0000]
Release commit for 0.31

4 years agoBumping version to 0.31
Graham Knop [Sun, 23 Apr 2017 19:42:28 +0000]
Bumping version to 0.31

4 years agochangelog
Graham Knop [Sun, 23 Apr 2017 19:41:50 +0000]
changelog

4 years agopod cleanups
Graham Knop [Sun, 9 Apr 2017 14:16:31 +0000]
pod cleanups

4 years agoinclude full rt link in pod
Graham Knop [Sun, 9 Apr 2017 14:06:15 +0000]
include full rt link in pod

4 years agofill out develop/suggests prereqs
Graham Knop [Sun, 9 Apr 2017 13:58:45 +0000]
fill out develop/suggests prereqs

4 years agoclean up module loading
Graham Knop [Sun, 9 Apr 2017 13:58:13 +0000]
clean up module loading

4 years agowhite space cleanups
Graham Knop [Sun, 9 Apr 2017 13:55:58 +0000]
white space cleanups

4 years agofix is_supported on General
Graham Knop [Sun, 9 Apr 2017 13:40:34 +0000]
fix is_supported on General

4 years agoalways run all tests during release
Graham Knop [Sun, 9 Apr 2017 13:32:52 +0000]
always run all tests during release

4 years agomove pod tests to xt/
Graham Knop [Sun, 9 Apr 2017 13:11:36 +0000]
move pod tests to xt/

4 years agobetter diagnostics on test failures
Graham Knop [Sun, 9 Apr 2017 13:09:06 +0000]
better diagnostics on test failures

4 years agostop using use_ok
Graham Knop [Sat, 8 Apr 2017 16:41:41 +0000]
stop using use_ok

4 years agoremove unneeded load test
Graham Knop [Sat, 8 Apr 2017 16:41:23 +0000]
remove unneeded load test

4 years agoRelease commit for 0.30 v0.30
Graham Knop [Tue, 28 Mar 2017 22:57:46 +0000]
Release commit for 0.30

4 years agoBumping version to 0.30
Graham Knop [Tue, 28 Mar 2017 22:57:11 +0000]
Bumping version to 0.30

4 years agochangelog
Graham Knop [Tue, 28 Mar 2017 22:57:03 +0000]
changelog

4 years agoavoid YAML::Syck on perl <= 5.8.8
Graham Knop [Mon, 27 Mar 2017 22:50:09 +0000]
avoid YAML::Syck on perl <= 5.8.8

4 years agoRelease commit for 0.29 v0.29
Graham Knop [Mon, 27 Feb 2017 10:24:23 +0000]
Release commit for 0.29

4 years agoBumping version to 0.29
Graham Knop [Mon, 27 Feb 2017 10:12:49 +0000]
Bumping version to 0.29

4 years agochangelog
Graham Knop [Mon, 27 Feb 2017 10:12:28 +0000]
changelog

4 years agothrow error for missing perl files
Graham Knop [Mon, 27 Feb 2017 10:10:52 +0000]
throw error for missing perl files

4 years agocheck for load failure rather than empty result
Graham Knop [Mon, 27 Feb 2017 10:10:27 +0000]
check for load failure rather than empty result

4 years agountaint cwd when constructing full perl file path
Graham Knop [Mon, 27 Feb 2017 10:01:24 +0000]
untaint cwd when constructing full perl file path

Previously, we would load perl files using a possibly relative path,
which would work based on . being in @INC.  Now that . is being removed,
we need to use an absolute path (or ./ relative path).  When
absolutizing, cwd would be used, which can be tained.  Although loading
based on . in @INC violates the spirit of taint, it had previously
worked and a downstream module expected it.  Untaint the cwd that gets
used so we can load relative paths under taint mode.

4 years agoRelease commit for 0.28 v0.28
Graham Knop [Tue, 21 Feb 2017 17:22:00 +0000]
Release commit for 0.28

4 years agoinclude test corpus in manifest
Graham Knop [Tue, 21 Feb 2017 17:21:12 +0000]
include test corpus in manifest

4 years agoBumping version to 0.28
Graham Knop [Sat, 18 Feb 2017 17:18:31 +0000]
Bumping version to 0.28

4 years agochangelog
Graham Knop [Sat, 4 Feb 2017 07:02:27 +0000]
changelog

4 years agodistar-ify
Graham Knop [Sat, 4 Feb 2017 06:59:25 +0000]
distar-ify

4 years agosupport Cpanel::JSON::XS and JSON::MaybeXS
Graham Knop [Sat, 4 Feb 2017 06:50:56 +0000]
support Cpanel::JSON::XS and JSON::MaybeXS

4 years agohandle UTF-8 data in JSON correctly
Graham Knop [Sat, 4 Feb 2017 06:45:54 +0000]
handle UTF-8 data in JSON correctly

4 years agorefactor option module loads for JSON subclass
Graham Knop [Sat, 4 Feb 2017 06:33:55 +0000]
refactor option module loads for JSON subclass

4 years agouse absolute paths when loading perl files
Graham Knop [Sat, 4 Feb 2017 06:29:16 +0000]
use absolute paths when loading perl files

The filenames provided to Config::Any are meant to be file paths.
If they are relative paths, they should be used directly, not searched
for in @INC.  Converting them to absolute paths will avoid that search,
and will allow it to work as expected when . is not in @INC.

5 years agoprep release mirror/master v0.27
Brian Cassidy [Thu, 31 Mar 2016 17:47:11 +0000]
prep release

5 years agodepend on Module::Pluggable::Object directly instead of assuming it is bundled with...
Brian Cassidy [Thu, 31 Mar 2016 17:44:09 +0000]
depend on Module::Pluggable::Object directly instead of assuming it is bundled with Module::Pluggable (RT #113148)

6 years agoprep release v0.26
Brian Cassidy [Wed, 29 Apr 2015 23:06:44 +0000]
prep release

6 years agoCapture file load errors for later use.
Russell Jenkins [Wed, 29 Apr 2015 00:49:14 +0000]
Capture file load errors for later use.

Localizing $@ also implies that any load error wasn't available outside
of the do block. Instead of always returning 1, return $@ so any error
is captured. The error is then rethrown if use_ext is enabled.

Signed-off-by: Brian Cassidy <brian.cassidy@gmail.com>

6 years agoTest load_files throws parse errors when use_ext=1
Russell Jenkins [Wed, 29 Apr 2015 00:48:45 +0000]
Test load_files throws parse errors when use_ext=1

Piggyback off existing tests for invalid config files to verify a parse
error is thrown when the config is invalid and use_ext => 1.

Signed-off-by: Brian Cassidy <brian.cassidy@gmail.com>

6 years agoprep release v0.25
Brian Cassidy [Fri, 24 Apr 2015 01:37:18 +0000]
prep release

6 years agodo not clobber $@ (RT #103061)
Brian Cassidy [Fri, 24 Apr 2015 01:32:31 +0000]
do not clobber $@ (RT #103061)

8 years agoprep release v0.24
Brian Cassidy [Tue, 10 Sep 2013 18:42:29 +0000]
prep release

8 years agoadd JSON::PP to list of available JSON parsers (RT #86959)
Brian Cassidy [Tue, 10 Sep 2013 18:38:35 +0000]
add JSON::PP to list of available JSON parsers (RT #86959)

8 years agoremove old YAML warning
Brian Cassidy [Tue, 10 Sep 2013 18:27:03 +0000]
remove old YAML warning

8 years agotypo fix (RT #87779)
Brian Cassidy [Thu, 15 Aug 2013 01:14:21 +0000]
typo fix (RT #87779)

10 years agoprep release v0.23
Brian Cassidy [Wed, 13 Jul 2011 15:18:07 +0000]
prep release

10 years agouse is_supported to figure out if we can test a loader
Brian Cassidy [Mon, 11 Jul 2011 14:10:16 +0000]
use is_supported to figure out if we can test a loader

10 years agoprep release v0.22
Brian Cassidy [Mon, 4 Jul 2011 14:48:00 +0000]
prep release

10 years agoadd XML::NamespaceSupport to XML format deps, silence YAML warnings in tests
Rafael Kitover [Mon, 4 Jul 2011 14:16:51 +0000]
add XML::NamespaceSupport to XML format deps, silence YAML warnings in tests

10 years agoprep release v0.21
Brian Cassidy [Wed, 25 May 2011 15:31:14 +0000]
prep release

10 years agoreformat Changes. bump copyright year.
Brian Cassidy [Wed, 25 May 2011 02:29:33 +0000]
reformat Changes. bump copyright year.

10 years agoupdate repo address
Brian Cassidy [Wed, 25 May 2011 02:15:57 +0000]
update repo address

10 years agofix t/64-extfail.t to pass when t/lib is in @INC
Brian Cassidy [Fri, 10 Dec 2010 18:16:41 +0000]
fix t/64-extfail.t to pass when t/lib is in @INC

11 years agoprep release v0.20
Brian Cassidy [Fri, 6 Aug 2010 11:49:02 +0000]
prep release

11 years agoremove useless "use Carp", squash warning in test suite.
Brian Cassidy [Thu, 5 Aug 2010 20:00:10 +0000]
remove useless "use Carp", squash warning in test suite.

11 years agotidy C::G related code, plus remove an old work-around which has been inactive for...
Brian Cassidy [Thu, 5 Aug 2010 19:41:54 +0000]
tidy C::G related code, plus remove an old work-around which has been inactive for years.

11 years agotidy Makefile.PL
Brian Cassidy [Thu, 5 Aug 2010 19:36:50 +0000]
tidy Makefile.PL

11 years agobetter version for Config::General
Rafael Kitover [Thu, 5 Aug 2010 01:45:10 +0000]
better version for Config::General

11 years agocroak if Config::General is too old
Rafael Kitover [Wed, 4 Aug 2010 20:11:24 +0000]
croak if Config::General is too old

11 years agobump ver. add to-be-released line to Changes.
Brian Cassidy [Wed, 4 Aug 2010 13:44:19 +0000]
bump ver. add to-be-released line to Changes.

11 years agoUse Config::Any's friendly error message for required version early on
Andrew Rodland [Mon, 2 Aug 2010 10:44:00 +0000]
Use Config::Any's friendly error message for required version early on

11 years agorequire Config::General >= 2.47
Rafael Kitover [Mon, 2 Aug 2010 10:39:25 +0000]
require Config::General >= 2.47

11 years agoenable -ForceArray option by default for Config::General
Rafael Kitover [Mon, 2 Aug 2010 10:00:37 +0000]
enable -ForceArray option by default for Config::General

11 years agoremove test. forgot to switch branches.
Brian Cassidy [Fri, 4 Jun 2010 14:35:17 +0000]
remove test. forgot to switch branches.

11 years agoadd leaktrace test
Brian Cassidy [Fri, 4 Jun 2010 14:32:56 +0000]
add leaktrace test

11 years agoprep release v0.19
Brian Cassidy [Mon, 15 Feb 2010 13:59:17 +0000]
prep release

11 years agoremove caching code from ::Perl
Rafael Kitover [Mon, 15 Feb 2010 13:52:28 +0000]
remove caching code from ::Perl

11 years agomake perl loader check mtime for cache, prefer JSON::DWIW for JSON
Rafael Kitover [Mon, 15 Feb 2010 12:17:50 +0000]
make perl loader check mtime for cache, prefer JSON::DWIW for JSON

12 years agoprep release v0.18
Brian Cassidy [Mon, 16 Nov 2009 13:02:45 +0000]
prep release

12 years agoensure XML loader's _coerce() method checks specifically for HASH refs
Brian Cassidy [Mon, 16 Nov 2009 12:49:59 +0000]
ensure XML loader's _coerce() method checks specifically for HASH refs

12 years agominor tidy to deprecation warning
Brian Cassidy [Tue, 21 Jul 2009 12:38:27 +0000]
minor tidy to deprecation warning

12 years agoadd warning about using YAML loaders other than ::XS
Rafael Kitover [Tue, 21 Jul 2009 11:37:40 +0000]
add warning about using YAML loaders other than ::XS

12 years agoadd YAML::XS to the top of the YAML loaders. tidy up some copyright lines.
Brian Cassidy [Tue, 21 Jul 2009 01:25:38 +0000]
add YAML::XS to the top of the YAML loaders. tidy up some copyright lines.

12 years agoAdd repository resource to all the MI Makefile.PLs
Tomas Doran [Sat, 23 May 2009 11:09:06 +0000]
Add repository resource to all the MI Makefile.PLs

12 years agoBump required Module::Install version in everything. janus++
Tomas Doran [Thu, 7 May 2009 13:19:53 +0000]
Bump required Module::Install version in everything. janus++

12 years agoadd JSON::XS to the top of the JSON loaders list v0.17
Brian Cassidy [Thu, 5 Feb 2009 14:32:56 +0000]
add JSON::XS to the top of the JSON loaders list

12 years agoensure require() happens against plugin specified in force_plugins
Brian Cassidy [Fri, 19 Dec 2008 12:54:48 +0000]
ensure require() happens against plugin specified in force_plugins

13 years agorevert change to extensions() as we really want *all* extensions. fix 10-branches... v0.16
Brian Cassidy [Mon, 17 Nov 2008 14:22:16 +0000]
revert change to extensions() as we really want *all* extensions. fix 10-branches to try only against .pl files.

13 years agofix up branches test which did not handle the errors thrown by changes from the last...
Brian Cassidy [Mon, 17 Nov 2008 13:40:15 +0000]
fix up branches test which did not handle the errors thrown by changes from the last release (RT #40948)
fix up error message for "any of" (RT #40972)

13 years agoupdate changes file v0.15
Brian Cassidy [Wed, 12 Nov 2008 14:48:24 +0000]
update changes file

13 years ago r37256@bricas-laptop (orig r8347): bricas | 2008-09-03 10:53:01 -0300
Brian Cassidy [Wed, 12 Nov 2008 14:44:22 +0000]
 r37256@bricas-laptop (orig r8347):  bricas | 2008-09-03 10:53:01 -0300
 branch for new feature
 r37257@bricas-laptop (orig r8348):  bricas | 2008-09-03 10:55:06 -0300
 when use_ext is true, we will check to see if there are no supported modules for a particular file. instead of the file being skipped, an error will be thrown.
 officially support multiple loaders per extension.
 add a Config::Any::Base for all loaders to inherit from, plus add a new dependency mechanism: requires_any_of() and requires_all_of().
 r37293@bricas-laptop (orig r8354):  bricas | 2008-09-04 10:52:33 -0300
 when use_ext is true, a fatal error will be thrown if there are no loaders available that understand the file extension
 r40211@bricas-laptop (orig r8589):  bricas | 2008-11-12 10:36:43 -0400
 filter out loaders that don't inherit from Config::Any::Base (RT #40830)
 r40212@bricas-laptop (orig r8590):  bricas | 2008-11-12 10:40:32 -0400
 add RT number

13 years agochanges file updated v0.14
Brian Cassidy [Wed, 6 Aug 2008 14:35:39 +0000]
changes file updated

13 years agoskip xml failure tests if XML::LibXML < 1.59 is installed, it seems to parse anything...
Brian Cassidy [Wed, 6 Aug 2008 13:40:03 +0000]
skip xml failure tests if XML::LibXML < 1.59 is installed, it seems to parse anything you throw at it (Matt S. Trout)

13 years agorelease date + misc. v0.13
Brian Cassidy [Tue, 5 Aug 2008 15:40:51 +0000]
release date + misc.

13 years agoline endings, tabs, perltidy.
Brian Cassidy [Tue, 5 Aug 2008 15:34:19 +0000]
line endings, tabs, perltidy.

13 years agoadded a flatten_to_hash option to return a simple key-value hashref instead of the...
Brian Cassidy [Tue, 5 Aug 2008 15:26:38 +0000]
added a flatten_to_hash option to return a simple key-value hashref instead of the default "arrayref of hashrefs" (Pedro Figueiredo)

13 years agoadded a caveat regarding XML::Simple's strict mode (Peter Corlett)
Brian Cassidy [Tue, 5 Aug 2008 15:05:58 +0000]
added a caveat regarding XML::Simple's strict mode (Peter Corlett)

13 years agoadd parse error tests. ensure INI errors are trapped. bumped version.
Brian Cassidy [Tue, 5 Aug 2008 12:03:26 +0000]
add parse error tests. ensure INI errors are trapped. bumped version.

13 years agoremove extra warn
Marcus Ramberg [Wed, 23 Jul 2008 11:39:01 +0000]
remove extra warn