fix for ini subsections (RT #32726), use from_json for JSON v2.x, refactor test suite.
[p5sagit/Config-Any.git] / Changes
diff --git a/Changes b/Changes
index 1b5e0e9..2adfc71 100644 (file)
--- a/Changes
+++ b/Changes
@@ -1,12 +1,25 @@
 Revision history for Config-Any
 
+0.11 Mon 28 Jan 2008
+    - fix subsection parsing for existing keys in INI files (RT #32726)
+    - use from_json() if JSON version 2.x is available
+    - refactor the test suite slightly
+
+0.10 Tue 11 Dec 2007
+    - promote dev release to stable
+
+0.09_02 Tue Nov 13 2007
+    - require version 0.70 of YAML::Syck for multi-document loading
+
 0.09_01 Tue Nov 13 2007
     - code and pod cleanups
     - use_ext is now on by default
-    - when use_ext is on, if a parser throws an error, we throw an error
+    - when use_ext is on, if a loader throws an error, we throw an error
     - fix case where use_ext is defined and false, but was behaving like
       use_ext => 1
-    - allow loaders to return multiple documents as an array.
+    - allow loaders to return multiple documents as an array
+    - each plugin now has an is_supported() method which helps us figure out
+      if the right modules are available
 
 0.08 Thu Aug 23 2007
     - pass config options to each parser