tweaked changes
[catagits/Catalyst-Runtime.git] / Makefile.PL
1 use strict;
2 use warnings;
3 use inc::Module::Install 0.91;
4 # Ensure that these get used - yes, M::I loads them for us, but if you're
5 # in author mode and don't have them installed, then the error is tres
6 # cryptic.
7 if ($Module::Install::AUTHOR) { # We could just use them, but telling
8     my @fail;                   # people the set of things they need nicer
9     foreach my $module (qw/
10         Module::Install::AuthorRequires
11         Module::Install::CheckConflicts
12         Module::Install::AuthorTests
13         Module::Install::Authority
14     /) {
15         push(@fail, $module)
16             unless eval qq{require $module; 1;};
17     }
18     die("Module::Install extensions failed, not installed? \n"
19         . join("\n", map { "  $_" } @fail) . "\n") if @fail;
20 }
21
22 perl_version '5.008003';
23
24 name 'Catalyst-Runtime';
25 author 'Sebastian Riedel <sri@cpan.org>';
26 authority('cpan:MSTROUT');
27 all_from 'lib/Catalyst/Runtime.pm';
28
29 requires 'List::MoreUtils';
30 requires 'namespace::autoclean' => '0.09';
31 requires 'namespace::clean' => '0.23';
32 requires 'MooseX::Emulate::Class::Accessor::Fast' => '0.00903';
33 requires 'Class::Load' => '0.12';
34 requires 'Data::OptList';
35 requires 'Moose' => '1.03';
36 requires 'MooseX::MethodAttributes::Role::AttrContainer::Inheritable' => '0.24';
37 requires 'MooseX::Role::WithOverloading' => '0.09';
38 requires 'Carp' => '1.25';
39 requires 'Class::C3::Adopt::NEXT' => '0.07';
40 requires 'CGI::Simple::Cookie' => '1.109';
41 requires 'Data::Dump';
42 requires 'Data::OptList';
43 requires 'HTML::Entities';
44 requires 'HTML::HeadParser';
45 requires 'HTTP::Body'    => '1.22';
46 requires 'HTTP::Headers' => '1.64';
47 requires 'HTTP::Request' => '5.814';
48 requires 'HTTP::Response' => '5.813';
49 requires 'HTTP::Request::AsCGI' => '1.0';
50 requires 'Module::Pluggable' => '4.7';
51 requires 'Path::Class' => '0.09';
52 requires 'Scalar::Util';
53 requires 'Sub::Exporter';
54 requires 'Text::SimpleTable' => '0.03';
55 requires 'Time::HiRes';
56 requires 'Tree::Simple' => '1.15';
57 requires 'Tree::Simple::Visitor::FindByPath';
58 requires 'Try::Tiny' => '0.17';
59 requires 'Safe::Isa';
60 requires 'Task::Weaken';
61 requires 'Text::Balanced'; # core in 5.8.x but mentioned for completeness
62 requires 'MRO::Compat';
63 requires 'MooseX::Getopt' => '0.48';
64 requires 'String::RewritePrefix' => '0.004'; # Catalyst::Utils::resolve_namespace
65 requires 'Devel::InnerPackage'; # No longer core in blead
66 requires 'Plack' => '0.9991'; # IIS6+7 fix middleware
67 requires 'Plack::Middleware::ReverseProxy' => '0.04';
68 requires 'Plack::Test::ExternalServer';
69 requires 'Class::Data::Inheritable';
70 requires 'Encode' => '2.49';
71 requires 'LWP' => '5.837'; # LWP had unicode fail in 5.8.26
72 requires 'URI' => '1.65';
73 requires 'URI::ws' => '0.03';
74 requires 'JSON::MaybeXS' => '1.000000';
75 requires 'Stream::Buffered';
76 requires 'Hash::MultiValue';
77 requires 'Plack::Request::Upload';
78 requires 'CGI::Struct';
79 requires "Plack::Middleware::Conditional";
80 requires "Plack::Middleware::IIS6ScriptNameFix";
81 requires "Plack::Middleware::IIS7KeepAliveFix";
82 requires "Plack::Middleware::LighttpdScriptNameFix";
83 requires "Plack::Middleware::ContentLength";
84 requires "Plack::Middleware::Head";
85 requires "Plack::Middleware::HTTPExceptions";
86 requires "Plack::Middleware::FixMissingBodyInRedirect" => '0.09';
87 requires "Plack::Middleware::MethodOverride" => '0.12';
88 requires "Plack::Middleware::RemoveRedundantBody" => '0.03';
89
90 test_requires 'Test::Fatal';
91 test_requires 'Test::More' => '0.88';
92 test_requires 'Data::Dump';
93 test_requires 'HTTP::Request::Common';
94 test_requires 'IO::Scalar';
95 test_requires 'HTTP::Status';
96 test_requires 'JSON::MaybeXS';
97
98 # see also cpanfile for authordeps -- install via
99 # cpanm --installdeps --with-develop .
100
101 # aggregate tests if AGGREGATE_TESTS is set and a recent Test::Aggregate and a Test::Simple it works with is available
102 my @author_requires;
103 if ($ENV{AGGREGATE_TESTS} && can_use('Test::Simple', '0.88') && can_use('Test::Aggregate', '0.364')) {
104     push(@author_requires, 'Test::Aggregate', '0.364');
105     push(@author_requires, 'Test::Simple', '0.88');
106     open my $fh, '>', '.aggregating';
107 }
108 else {
109     unlink '.aggregating';
110     tests 't/*.t t/aggregate/*.t';
111 }
112
113 push(@author_requires, 'CatalystX::LeakChecker', '0.05');
114 push(@author_requires, 'Catalyst::Devel', '1.0'); # For http server test
115 push(@author_requires, 'Test::WWW::Mechanize::Catalyst', '0.51');
116 push(@author_requires, 'Test::TCP', '2.00'); # ditto, ships Net::EmptyPort
117
118 author_tests('t/author');
119 author_requires(
120   @author_requires,
121   map {; $_ => 0 } qw(
122   File::Copy::Recursive
123   Test::Without::Module
124   Starman
125   MooseX::Daemonize
126   Test::NoTabs
127   Test::Pod
128   Test::Pod::Coverage
129   Test::Spelling
130   Pod::Coverage::TrustPod
131   Catalyst::Plugin::Params::Nested
132   Catalyst::Plugin::ConfigLoader
133 ));
134
135 if ($Module::Install::AUTHOR) {
136     darwin_check_no_resource_forks();
137 }
138
139 resources(
140     'MailingList' => 'http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst',
141     'IRC'         => 'irc://irc.perl.org/#catalyst',
142     'license',    => 'http://dev.perl.org/licenses/',
143     'homepage',   => 'http://dev.catalyst.perl.org/',
144     # r/w: catagits@git.shadowcat.co.uk:Catalyst-Runtime.git
145     'repository', => 'git://git.shadowcat.co.uk/catagits/Catalyst-Runtime.git',
146 );
147
148 install_script glob('script/*.pl');
149 auto_install;
150 WriteAll;
151
152 print <<"EOF";
153
154  Important:
155
156     This library is for running Catalyst applications.
157
158     For development and use of catalyst.pl and myapp_create.pl, make sure
159     you also install the development tools package Catalyst::Devel.
160
161         perl -MCPANPLUS -e 'install Catalyst::Devel' # or
162         perl -MCPAN -e 'install Catalyst::Devel'     # or
163         cpanm Catalyst::Devel
164
165     To get some commonly used plugins, as well as the TT view and DBIC
166     model, install Task::Catalyst in the same way.
167
168  Have fun!
169 EOF
170
171 # NOTE - This is the version number of the _incompatible_ code,
172 #        not the version number of the fixed version.
173 my %conflicts = (
174     'Catalyst::Plugin::SubRequest' => '0.14',
175     'Catalyst::Model::Akismet' => '0.02',
176     'Catalyst::Component::ACCEPT_CONTEXT' => '0.06',
177     'Catalyst::Plugin::ENV' => '9999', # This plugin is just stupid, full stop
178                                        # should have been a core fix.
179     'Catalyst::Plugin::Unicode::Encoding' => '0.2',
180     'Catalyst::Plugin::Authentication' => '0.10010', # _config accessor in ::Credential::Password
181     'Catalyst::Authentication::Credential::HTTP' => '1.009',
182     'Catalyst::Plugin::Session::Store::File'     => '0.16',
183     'Catalyst::Plugin::Session'                  => '0.21',
184     'Catalyst::Plugin::Session::State::Cookie'   => '0.10',
185     'Catalyst::Plugin::Session::Store::FastMmap' => '0.09',
186     'Catalyst::Controller::AllowDisable'         => '0.03',
187     'Reaction'                                   => '0.001999',
188     'Catalyst::Plugin::Upload::Image::Magick'    => '0.03',
189     'Catalyst::Plugin::ConfigLoader'             => '0.22', # Older versions work but
190                                                   # throw Data::Visitor warns
191     'Catalyst::Devel'                            => '1.19',
192     'Catalyst::Plugin::SmartURI'                 => '0.032',
193     'CatalystX::CRUD'                            => '0.37',
194     'Catalyst::Action::RenderView'               => '0.07',
195     'Catalyst::Plugin::DebugCookie'              => '0.999002',
196     'Catalyst::Plugin::Authentication'           => '0.100091',
197     'CatalystX::Imports'                         => '0.03',
198     'Catalyst::Plugin::HashedCookies'            => '1.03',
199     'Catalyst::Action::REST'                     => '0.67',
200     'CatalystX::CRUD'                            => '0.42',
201     'CatalystX::CRUD::Model::RDBO'               => '0.20',
202     'Catalyst::View::Mason'                      => '0.17',
203 #    Note these are not actually needed - they fail tests against the
204 #    new version, but still work fine..
205 #    'Catalyst::ActionRole::ACL'                  => '0.05',
206 #    'Catalyst::Plugin::Session::Store::DBIC'     => '0.11',
207       'Test::WWW::Mechanize::Catalyst'            => '0.53', # Dep warnings unless upgraded.
208 );
209 check_conflicts(%conflicts);
210
211 # End of script, helper functions below.
212
213 sub darwin_check_no_resource_forks {
214     if ($^O eq 'darwin') {
215         my $osx_ver = `/usr/bin/sw_vers -productVersion`;
216         chomp $osx_ver;
217
218         # TAR on 10.4 wants COPY_EXTENDED_ATTRIBUTES_DISABLE
219         # On 10.5 (Leopard) it wants COPYFILE_DISABLE
220         my $attr = $osx_ver =~ /^10.(5|6|7|8)/  ? 'COPYFILE_DISABLE' : 'COPY_EXTENDED_ATTRIBUTES_DISABLE';
221
222         makemaker_args(dist => { PREOP => qq{\@if [ "\$\$$attr" != "true" ]; then}.
223                                           qq{ echo "You must set the ENV variable $attr to 'true',"; }.
224                                           ' echo "to avoid getting resource forks in your dist."; exit 255; fi' });
225     }
226 }